Maintenance records - Kia Niro Forum
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old Today, 02:12 PM Thread Starter
Junior Member
 
Join Date: Sep 2018
Location: SE US
Posts: 10
Maintenance records

I was wondering if maintenance records would be accessible online for any work done on my Niro by my dealer. The owners page

https://owners.kia.com/content/owner...ashboard.html/

seems to imply that it will be but my owners page doesn't have my dealership oil changes listed plus the mileage is not even close to being correct. Does anybody know if this functionality is supposed to exist or if there is another way to get it online?
cbear is online now  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old Today, 02:32 PM
Senior Member
 
Join Date: Jul 2018
Location: Daytona Beach, Fl.
Posts: 181
From what I see it's up to the owner to enter the records. Sorta bummer. I know Toyota when you too it to a dealer the records would show up in a day or 2.

Gene Daytona Beach Beach, Fl.
2018 Kia Niro LX 7/11/18-
FlNiro is online now  
post #3 of 6 (permalink) Old Today, 03:40 PM
Super Moderator
 
atc98092's Avatar
 
Join Date: May 2019
Location: Auburn WA
Posts: 147
When you log into the owners page, you have to refresh the info to have correct mileage and battery charge (PHEV and EV). Just opening the page doesn't cause a refresh. There will be a line labeled "Last Refreshed" and a time/days amount. Click that to refresh the info.

Dan
2019 Kia Niro PHEV EX Premium

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
atc98092 is online now  
post #4 of 6 (permalink) Old Today, 07:52 PM
Senior Member
 
Join Date: Jul 2018
Location: Daytona Beach, Fl.
Posts: 181
I don't see that line anywhere?

Gene Daytona Beach Beach, Fl.
2018 Kia Niro LX 7/11/18-
FlNiro is online now  
post #5 of 6 (permalink) Old Today, 08:09 PM
Senior Member
 
Join Date: Apr 2018
Location: Southern MD
Posts: 255
Garage
Quote:
Originally Posted by FlNiro View Post
I don't see that line anywhere?
It's not obvious and there's nothing to indicate it's an active link. This is what I see when I log in (arrow indicates the hard to spot link):
Attached Thumbnails
Click image for larger version

Name:	Slide1.JPG
Views:	7
Size:	79.8 KB
ID:	5159  

Jim
Southern Maryland
jmurphEV is online now  
post #6 of 6 (permalink) Old Today, 09:10 PM
Senior Member
 
Join Date: Jul 2018
Location: Daytona Beach, Fl.
Posts: 181
My page doesn't look like that? Do you have to have UVO connected? I don't have mine connected I wonder if that's the problem?

Gene Daytona Beach Beach, Fl.
2018 Kia Niro LX 7/11/18-
FlNiro is online now  
Reply




Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome