Mechanical question....engine temperature gauge? - Kia Niro Forum
 4Likes
  • 1 Post By basicbill
  • 3 Post By realto
 
LinkBack Thread Tools
post #1 of 7 (permalink) Old 07-08-2017, 11:16 PM Thread Starter
Member
 
basicbill's Avatar
 
Join Date: Mar 2017
Location: Western Canada
Posts: 69
Mechanical question....engine temperature gauge?

I like all of the features that are shown on the display panel, but I haven't found any sign of a temperature gauge. Is there a dedicated display for engine temperature?
extech67 likes this.
basicbill is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 07-09-2017, 09:53 PM
Senior Member
 
Join Date: Mar 2017
Posts: 214
Quote:
Originally Posted by basicbill View Post
I like all of the features that are shown on the display panel, but I haven't found any sign of a temperature gauge. Is there a dedicated display for engine temperature?
Yes, you press the page symbol button until it gets to the wrench symbol in center of dash, then toggle until you get to engine temp.
lrpavlo, basicbill and extech67 like this.
realto is offline  
post #3 of 7 (permalink) Old 07-13-2017, 03:03 PM Thread Starter
Member
 
basicbill's Avatar
 
Join Date: Mar 2017
Location: Western Canada
Posts: 69
Thanks Realto...don't know how I could have missed it!
basicbill is offline  
post #4 of 7 (permalink) Old 05-09-2018, 03:19 PM
Junior Member
 
Join Date: Apr 2018
Posts: 5
engine temp gauge always reads hot

engine temp gauge As I was familiarizing myself with the various screens I opened the engine temp gauge window and saw that it was all the way up with a red rectangle around the top. I've been driving in straight EV mode for weeks now, so don't see how the engine cold be anything other than cold. I have not seen any temperature warning icons on the main screen. Anyone know anything about this? Thanks,
Stein is offline  
post #5 of 7 (permalink) Old 05-09-2018, 06:40 PM
Senior Member
 
Join Date: Aug 2017
Posts: 332
My Ultragauge has a temperature gauge. The regular hybrid ICE runs just over 200 degrees after it is warmed up and running.

Seems just about right to me.

I wonder if your gauge isnt working because the engine isnt running. Perhaps it needs to run to "reset".
Griswald is online now  
post #6 of 7 (permalink) Old 05-09-2018, 08:14 PM
Junior Member
 
Join Date: Apr 2018
Posts: 5
Thanks, Griswald but I think I figured it out. That red thing at the top of the thermometer is just part of the graphic display, rather than an actual indication. I don't think it's reading anything because with the gas engine off it's just not an issue. Next time the gas engine is running, which I expect to be about a month from now, I'll check back and see what an actual indication looks like.
Stein is offline  
post #7 of 7 (permalink) Old 05-09-2018, 10:54 PM
Senior Member
 
Join Date: Mar 2017
Location: SW Ohio
Posts: 1,786
It so far only goes to one bar under half "hot" in my HEV. Yes, there is a red bar on top of the graph but the indicator never goes that high. Hopefully there is an idiot light that comes on before that happens.

2018 Kia LX HEV Metal Stream with Advanced Tech
yticolev is online now  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mechanical question....air conditioner basicbill Kia Niro General Discussion 6 07-04-2017 07:50 PM
Mechanical question... Starter basicbill Kia Niro General Discussion 10 06-23-2017 03:17 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome