12V output - Kia Niro Forum
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 09-21-2017, 11:40 AM Thread Starter
Junior Member
 
Join Date: Sep 2017
Posts: 3
12V output

The other day when we were at the races we were trying to plug something in to the 12v. When you turn the car off, it stops working.
Even in my husbands 2000 Silverado, he has "3" 12V outlets, one of them will continue running with the vehicle turned off. Is this normal for the Kia Niro Touring? Thanks !
Msldyblue is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 09-21-2017, 03:45 PM
Member
 
Join Date: Mar 2017
Posts: 35
The one thing that irks me the most is the poor power outlet setup. The USB ones are low power and nothing works unless the car is running, even the 12 volt inverter outlet on my Touring. Rapid USB power, at least one 12 V that runs regardless.
jmcging is offline  
post #3 of 4 (permalink) Old 09-21-2017, 04:18 PM
Senior Member
 
Join Date: Aug 2017
Posts: 333
Hybrid cars have a very limited 12 volt battery. Even my Fusion would only work for 20 minutes after the vehicle was shut off.

Dead battery in a hybrid is a world of trouble.
Griswald is offline  
post #4 of 4 (permalink) Old 09-21-2017, 07:52 PM
Senior Member
 
Join Date: Jan 2017
Posts: 174
^Yeah they are usually 10 amps not 12 too, the niro is no different.
fernando is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome