Drive system failed in stop and go traffic - Kia Niro Forum
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 12-05-2018, 07:08 AM Thread Starter
Junior Member
 
Join Date: Jan 2018
Posts: 3
Drive system failed in stop and go traffic

Stuck in traffic jam for two hours. Watched the charge gauge drop down to three bars. Gas engine wasn't being called often enough to keep a normal level of charge. Car stopped. No gas drive or electric motor drive. Put it in neutral, nothing. Put it in sport mode and engine started. Got through the traffic jam and once the battery had been charged up to a normal level I put it back in drive. Now everything back to normal. Off to the dealer today to see if any abnormalities were recorded on the computer.
Thosbryan is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 12-06-2018, 09:33 PM
Member
 
Join Date: Jul 2018
Posts: 37
Quote:
Originally Posted by Thosbryan View Post
Stuck in traffic jam for two hours. Watched the charge gauge drop down to three bars. Gas engine wasn't being called often enough to keep a normal level of charge. Car stopped. No gas drive or electric motor drive. Put it in neutral, nothing. Put it in sport mode and engine started. Got through the traffic jam and once the battery had been charged up to a normal level I put it back in drive. Now everything back to normal. Off to the dealer today to see if any abnormalities were recorded on the computer.
If it ever happens again, you might try raising the interior temperature knob to max and then turn on the Blower FAN. That thing will pretty much start the gasoline engine anytime, even if the battery level is up around 80%. Unfortunately, it also takes a big bite out of fuel economy.
achr is offline  
post #3 of 4 (permalink) Old 12-15-2018, 05:34 PM
Senior Member
 
Join Date: Sep 2017
Posts: 219
I saw the battery drop well down during a big traffic jam but the ice would kick in if it got too low to charge back up the battery, so never saw that issue. So it may be some flaw.
fredct is offline  
post #4 of 4 (permalink) Old 12-16-2018, 02:21 AM
Member
 
Join Date: Oct 2018
Location: Greater Vancouver, Canada
Posts: 36
I've had my PHEV battery down to 6%, and also had the 'check hybrid system' come on twice, but go off after cycling the system off and on.
It is concerning.
Orac is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Tech Package - autonomous braking system FAILED! Dan Kia Niro General Discussion 52 06-13-2018 08:27 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome