In the shop for a month - Kia Niro Forum
 1Likes
  • 1 Post By DocWillie
 
LinkBack Thread Tools
post #1 of 7 (permalink) Old 01-09-2019, 02:44 PM Thread Starter
Junior Member
 
Join Date: Sep 2018
Posts: 6
In the shop for a month

In August, I bought a 2-17 Niro EX with only 5000 miles on it. A couple months ago I started getting Check Engine and Check Hybrid System lights, although the car was running fine. I took it in for the recalls, and had them check out why the warning lights. Long story short, they have had the car for four weeks, finding the warning that there was a bad traction battery module connection, but after fixing that the warnings stayed. I am now waiting for a new traction battery to be shipped and installed. Kia Central has been involved, and the dealer has given me a loaner car.

I just hope I don't have a lemon.
DocWillie is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 01-09-2019, 04:56 PM
TK6
Member
 
TK6's Avatar
 
Join Date: Aug 2018
Location: Bay Area, California
Posts: 33
Sorry to hear that. Hopefully they get it back to you soon and the problem has been truly fixed.

2018 Kia Niro PHEV EX Premium
Silver with black interior
TK6 is offline  
post #3 of 7 (permalink) Old 01-26-2019, 12:32 PM
Junior Member
 
Join Date: Dec 2018
Posts: 20
Quote:
Originally Posted by DocWillie View Post
In August, I bought a 2-17 Niro EX with only 5000 miles on it. A couple months ago I started getting Check Engine and Check Hybrid System lights, although the car was running fine. I took it in for the recalls, and had them check out why the warning lights. Long story short, they have had the car for four weeks, finding the warning that there was a bad traction battery module connection, but after fixing that the warnings stayed. I am now waiting for a new traction battery to be shipped and installed. Kia Central has been involved, and the dealer has given me a loaner car.

I just hope I don't have a lemon.
Good day. Too bad you experienced the same error i got from a brand new 2019 Niro, bought last Dec 28, 2018. I hade the same error when the temp is so cold (-18 below)and the Car wont start. Been in and out or the dealership 3x. Hope it will be fixed this time. Were ypu able to grt ur vehicle back this time? We are located in Manitoba btw. May i know where u at?
Nestor Tee Martinez II is offline  
post #4 of 7 (permalink) Old 01-27-2019, 08:16 AM Thread Starter
Junior Member
 
Join Date: Sep 2018
Posts: 6
I am in the Mid-Hudson Valley area of New York. Problem did emerge when the weather got cold.

I got the car back after exactly four weeks, with a traction battery replacement. Covered by warranty.

KIA central had called and said they would offer me something to compensate me, but now I have not heard from them, in spite of emailing them.

Car is running fine now.
TK6 likes this.
DocWillie is offline  
post #5 of 7 (permalink) Old 01-27-2019, 10:44 AM
Senior Member
 
Join Date: Jul 2018
Location: Daytona Beach, Fl.
Posts: 209
Quote:
Originally Posted by DocWillie View Post
I am in the Mid-Hudson Valley area of New York. Problem did emerge when the weather got cold.

I got the car back after exactly four weeks, with a traction battery replacement. Covered by warranty.

KIA central had called and said they would offer me something to compensate me, but now I have not heard from them, in spite of emailing them.

Car is running fine now.
Good to hear your problem has been resolved. I remember you from Prius Chat. Let us know if you ever get compensated and hope your Niro stays problem free.

Gene Daytona Beach Beach, Fl.
2018 Kia Niro LX 7/11/18-
FlNiro is online now  
post #6 of 7 (permalink) Old 01-29-2019, 01:46 PM
Junior Member
 
Join Date: Dec 2018
Posts: 20
Quote:
Originally Posted by DocWillie View Post
I am in the Mid-Hudson Valley area of New York. Problem did emerge when the weather got cold.

I got the car back after exactly four weeks, with a traction battery replacement. Covered by warranty.

KIA central had called and said they would offer me something to compensate me, but now I have not heard from them, in spite of emailing them.

Car is running fine now.
Thats good news. I hope your car will stay OK. Did kia confirm that the cold was the reason for the error? May i know how cold was it that time when your vehicle had that problem? Maybe i can suggest Kia canada to check my cars traction battery. They've been it contact with the technical Assistance and engineers from B.C. but untill now they cant seem to get to the root of the problem.
Nestor Tee Martinez II is offline  
post #7 of 7 (permalink) Old 01-30-2019, 07:39 AM Thread Starter
Junior Member
 
Join Date: Sep 2018
Posts: 6
The cold is not the cause, merely the condition that exposes the fault. The techs were getting error codes indicating bad connections to one or more of the battery cells. The entire battery got replaced.
DocWillie is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
4 month status questions and answers brandent Kia Niro: Likes And Dislikes 9 01-15-2019 03:08 PM
2018+ Kia Niro EV U.S. Release Date, etc.? GHTech 2018+ Kia Niro EV General Discussion 6 10-27-2018 04:46 AM
Kia Niro Nine Month Test: Part 1 Kia Niro News 2017+ Kia Niro News 4 04-12-2017 06:48 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome