Kia infotainment system screen and CarPlay - Page 2 - Kia Niro Forum
 1Likes
Reply
 
LinkBack Thread Tools
post #11 of 15 (permalink) Old 06-13-2019, 04:10 PM
Super Moderator
 
atc98092's Avatar
 
Join Date: May 2019
Location: Auburn WA
Posts: 150
Quote:
Originally Posted by dsh72 View Post
I paid for an extended warranty on all electrical components on this vehicle through my dealership. I can guarantee that this head unit will go out before the 10 year warranty. Most computers I work on barely last 2-3 years. I had an old IBM think-pad and it lasted over 5 years...it just became obsolete at some point. Electronic components will give out...it's just a matter of when.
That's a rather bold guarantee. But I agree that electronics have a lifespan that rarely equals non-technical devices. However, from what I've read here it's nothing compared to the head unit issue Subaru has been dealing with on their 2017-18 Outbacks. I had mine for 1 1/2 years, and the H/U went out a half dozen times. I was one of the fortunate ones, in that mine always started working again after a long enough stop. But many, many owners had their H/U replaced more than once. They might have finally gotten a firmware version that completely resolved it, but if it bricked before getting it installed you were out of luck.

I also have to say the voice recognition of the Kia H/U is noticeably better than the Subaru. Amazing since they are Harmon-Kardon units. Sometimes if was impossible for my Outback to recognize "home" when trying to voice dial. Some of the matches it came up with you won't believe. While I usually use CarPlay, the Kia has "called home" without making an error once.

Dan
2019 Kia Niro PHEV EX Premium

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
atc98092 is online now  
Sponsored Links
Advertisement
 
post #12 of 15 (permalink) Old 06-20-2019, 06:35 PM
Junior Member
 
Join Date: Jun 2018
Posts: 22
I have had the black screen problem maybe 4-5 times over about one year. It always resolves for me by just disconnecting my phone and plugging it back in. I have been assuming a flaky cable since I bought it on Monoprice and am fairly rough with it.

The "slipping" issue I have not seen. If you can reproduce these problems I would show the dealer and get them to fix it or replace the unit.
spankym is offline  
post #13 of 15 (permalink) Old 06-20-2019, 06:37 PM
Junior Member
 
Join Date: Jun 2018
Posts: 22
FWIW, this is the cable I use. I would suggest getting one or two spares to keep in the car: https://www.monoprice.com/product?p_id=30784
spankym is offline  
post #14 of 15 (permalink) Old 06-22-2019, 08:46 AM
Member
 
TheSilverFlash's Avatar
 
Join Date: Jun 2019
Location: Knoxville, TN
Posts: 57
Quote:
Originally Posted by Nancy Gottovi View Post
Hi. I have a 2019 Kia Niro PHEV that I bought in December 2018. The display screen has periodically gone black and as many people have mentioned, I had to pull over and turn the car off and back on again and the screen came back on again. (But what a pain for a new car, especially traveling down the interstate.)
You all know there is a reset button just to the right of the volume knob right? It will reset the headunit if it goes blank. It has happened to me already (only have 500 miles) and pushing the reset button while driving reset the unit and brought it back online. No need to pull over and turn car off and back on.

Paul
2019 Kia Niro PHEV EX Premium Silky Silver
2016 Mazda CX-5 GT Soul Red

Last edited by TheSilverFlash; 06-22-2019 at 08:48 AM.
TheSilverFlash is online now  
post #15 of 15 (permalink) Old 06-23-2019, 01:09 PM
Senior Member
 
Join Date: Oct 2018
Location: Murrieta, CA
Posts: 314
Kia has released a software update that might help people with the black screen problem. Ask your service garage about TSBELE162_R1 (released last December and revised in April). If they don't recognize that number, ask them about issue number SA366. But obviously, a software update isn't going to correct the "slipping" problem that Nancy Gottovi mentioned, which sounds like the head unit wasn't properly installed to begin with.
TheSilverFlash likes this.

2018 Niro PHEV Gravity Blue
deltasmith is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome