Apple Carplay connection issues - Kia Niro Forum
Reply
 
LinkBack Thread Tools
post #1 of 16 (permalink) Old 07-07-2018, 04:53 PM Thread Starter
Junior Member
 
Join Date: Jun 2018
Posts: 20
Garage
Apple Carplay connection issues

Only happens every so often, but sometimes when I plug my iphone into the car the CarPlay won’t connect and I have to try again. I notice it most when I do it as soon as the car is started even before the navigation boots up. I am trying to see if maybe the Bluetooth connection is the problem since it also tries to connect to the phone at the same time I usually plug it into the usb. I have a 2017 niro ex with navigation and a mifi certified lightning usb connector. I read in some other threads people have had trouble with usb connection on ipods and usb media drives.
Ruzzell is offline  
Sponsored Links
Advertisement
 
post #2 of 16 (permalink) Old 07-07-2018, 08:12 PM
Senior Member
 
Join Date: Mar 2017
Location: SW Ohio
Posts: 1,721
Try a different USB cable. Many aftermarket cables (non-Apple) have crappy Lightning connection. You can test this by replugging in the iPhone. I even have had Apple cables that only work on one orientation so I would also check that by flipping the connector.

2018 Kia LX HEV Metal Stream with Advanced Tech
yticolev is online now  
post #3 of 16 (permalink) Old 07-07-2018, 11:35 PM
Member
 
Join Date: Apr 2018
Posts: 88
Quote:
Originally Posted by yticolev View Post
Try a different USB cable. Many aftermarket cables (non-Apple) have crappy Lightning connection. You can test this by replugging in the iPhone. I even have had Apple cables that only work on one orientation so I would also check that by flipping the connector.
This is certainly the culprit....have run across it with several "Zon type knockoffs. Look for official Apple or make sure the off brands are Apple compliant...MFi is the term to search. AmazonBasics house brand would do the trick and are cheaper than Apple markup stuff.

2018 Niro Touring "Rich Espresso"


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tonepad is offline  
post #4 of 16 (permalink) Old 07-07-2018, 11:54 PM
Member
 
Join Date: Apr 2018
Posts: 88
I have no lag connecting CarPlay with proper cables. It's pretty quick.

2018 Niro Touring "Rich Espresso"


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tonepad is offline  
post #5 of 16 (permalink) Old 07-08-2018, 12:22 AM
Senior Member
 
KK6PD's Avatar
 
Join Date: Dec 2017
Location: Foothills of Los Angeles
Posts: 173
Garage
If you can't use WiFi or Blu-tooth to connect apple car play, and are forced to use a cord, that makes apple car pay pretty much USELESS in my book......

73's de Pat KK6PD


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
KK6PD is offline  
post #6 of 16 (permalink) Old 07-08-2018, 08:16 AM
Member
 
Billraab's Avatar
 
Join Date: Aug 2017
Location: Minneapolis, MN
Posts: 44
To each their own. I hate Bluetooth and don’t use it but happily plug my phone in and use CarPlay which works awesome.
Billraab is offline  
post #7 of 16 (permalink) Old 07-08-2018, 08:48 AM Thread Starter
Junior Member
 
Join Date: Jun 2018
Posts: 20
Garage
I have been using mifi cord from monoprice. I think having the bluetooth pairing as the same time as connecting to carplay may have caused some issues. Seems to be working better now that I turned bluetooth pairing off
Ruzzell is offline  
post #8 of 16 (permalink) Old 07-14-2018, 05:44 PM
Junior Member
 
Join Date: Apr 2018
Posts: 6
In my (2018) Niro the bluetooth automatically disconnects if the same phone is connected to CarPlay via USB cable.

I do sometimes get this issue where the CarPlay isn't recognized and reconnecting the cable it then works. I do have a genuine Apple cable. I just put it down to buggy software as it doesn't happen very often.
nirokim is offline  
post #9 of 16 (permalink) Old 07-15-2018, 04:01 PM
Senior Member
 
Join Date: Sep 2017
Posts: 219
Quote:
Originally Posted by KK6PD View Post
If you can't use WiFi or Blu-tooth to connect apple car play, and are forced to use a cord, that makes apple car pay pretty much USELESS in my book......
As someone who has been “using” it just fine for 10 months that way... um, why?
fredct is offline  
post #10 of 16 (permalink) Old 07-15-2018, 07:07 PM
Senior Member
 
KK6PD's Avatar
 
Join Date: Dec 2017
Location: Foothills of Los Angeles
Posts: 173
Garage
Quote:
Originally Posted by fredct View Post
As someone who has been “using” it just fine for 10 months that way... um, why?

Why is it worthless? Well my dash port is currently home to my Ipod, no other port to plug a phone into, besides, I have WiFi/Bluetooth on my phone, if Carplay is so useful & cool, then why won't it work with those 2 mediums??
To lock the connection into a cord only, is simply stupid..... and worthless to me!

73's de Pat KK6PD


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
KK6PD is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
6" cable for CarPlay Xaqtly Kia Niro General Discussion 6 07-15-2018 10:10 PM
CarPlay Random Disconnects nirokim Kia Niro Issues, Problems And Complaints 9 06-01-2018 10:02 PM
Apple car play Randal70 Kia Niro General Discussion 5 04-12-2017 03:39 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome