UVO Eco App - Kia Niro Forum
 4Likes
Closed Thread
 
LinkBack Thread Tools
post #1 of 42 (permalink) Old 08-11-2018, 02:03 AM Thread Starter
Member
 
Join Date: Jul 2018
Location: Western WA
Posts: 53
Question UVO Eco App

I downloaded the UVO Eco App to use with my 2018 Niro PHEV. Everything seems to work fine except for setting the vehicle climate. Most of the app reviewers complain the climate function doesn't work for them too. Is there something all of us are missing about the climate functionality or is this function simply unworkable?
hawke is offline  
Sponsored Links
Advertisement
 
post #2 of 42 (permalink) Old 08-11-2018, 02:17 PM
Member
 
Join Date: Apr 2018
Posts: 39
I didn't have a problem setting climate control in my PHEV from the app, I'm using an iphone 5S. Where my problem lies with the app is that I can only use it once and then it won't work and then I have to delete the app and then re download it. Anybody have any clues on why this is??
egmacrae is offline  
post #3 of 42 (permalink) Old 08-12-2018, 09:49 AM
Senior Member
 
Join Date: Apr 2018
Location: Southern MD
Posts: 381
Garage
Quote:
Originally Posted by hawke View Post
I downloaded the UVO Eco App to use with my 2018 Niro PHEV. Everything seems to work fine except for setting the vehicle climate. Most of the app reviewers complain the climate function doesn't work for them too. Is there something all of us are missing about the climate functionality or is this function simply unworkable?
The app works fine with my PHEV including the climate control, but you have to make sure the vehicle is locked when you try it. I forget sometimes and it's annoying because there's no indication in the app that reminds you to lock it, it just fails.
safari and hawke like this.

Jim
Southern Maryland / Washington DC
2018 Snow White Pearl EX Premium PHEV
jmurphEV is online now  
post #4 of 42 (permalink) Old 08-12-2018, 02:10 PM Thread Starter
Member
 
Join Date: Jul 2018
Location: Western WA
Posts: 53
Question Why The Flashing Car Lights During Climate Operation?

Thanks so much Jim for the information. I locked my Niro and the app's climate settings worked perfectly. My follow-up question is why do the front and rear orange car lights flash during climate operation? I cooled and heated the vehicle to test the app and ran each for a few minutes but the orange lights didn't stop flashing. Is this built into the remote climate functionality and if so, why?
hawke is offline  
post #5 of 42 (permalink) Old 08-12-2018, 05:45 PM
Senior Member
 
Join Date: Apr 2018
Location: Southern MD
Posts: 381
Garage
Quote:
Originally Posted by hawke View Post
Thanks so much Jim for the information. I locked my Niro and the app's climate settings worked perfectly. My follow-up question is why do the front and rear orange car lights flash during climate operation? I cooled and heated the vehicle to test the app and ran each for a few minutes but the orange lights didn't stop flashing. Is this built into the remote climate functionality and if so, why?
I'm not sure why the flashers are on when the climate is activated remotely, but it's definitely a feature. Probably some safety thing.

Jim
Southern Maryland / Washington DC
2018 Snow White Pearl EX Premium PHEV
jmurphEV is online now  
post #6 of 42 (permalink) Old 08-17-2018, 07:25 PM
Junior Member
 
Join Date: Jun 2018
Posts: 22
I'm pretty happy with the app and it always seems to work for me. The only thing that bugs me a bit is when heating it turns on the steering wheel heater and rear defrost automatically. It would be nice to be able to select those on and off. It would also be nice to select the seat heat.

Perfect for me would be to just heat the drivers seat and steering wheel for a few minutes before getting in the car in the morning many days
spankym is offline  
post #7 of 42 (permalink) Old 05-08-2019, 12:02 PM
Mal
Senior Member
 
Mal's Avatar
 
Join Date: Dec 2018
Posts: 141
Reviving an old thread. I have been using the app quite a bit. It is a bit buggy and certainly not up to Tesla standards but it works. My battery range is more often incorrect than correct and often trips don't download but both problems seem intermittent. I have tested the climate setting but won't use it much until I figure out the HVAC system in normal operation....
Mal is offline  
post #8 of 42 (permalink) Old 05-09-2019, 12:18 PM
Junior Member
 
Join Date: Mar 2019
Posts: 4
I have an I phone 5S and I log into UVO using the fingerscan feature. When it's working correctly it populates user name and then asks for fingerscan. Sometimes UVO will ask for user name and password. When this happens it fails to log in (despite entering correct credentials). Has anybody had a similar experience?

Last edited by Dougiefresh; 05-09-2019 at 12:22 PM.
Dougiefresh is offline  
post #9 of 42 (permalink) Old 05-10-2019, 03:28 PM
Super Moderator
 
Join Date: May 2018
Location: Montreal, Canada
Posts: 462
Garage
Quote:
Originally Posted by Mal View Post
It is a bit buggy and certainly not up to Tesla standards but it works. My battery range is more often incorrect than correct and often trips don't download but both problems seem intermittent.
You guy's in the states are quite lucky to have this app, up north, the app for PHEV is still horrible. i have mine since december 2018 (one of the first 10 phev sold in canada), and i still does not have the same version that all new PHEV has now, no charging info, connected or not etc.. opened a ticket at Kia Canada, and since 2 weeks, noooo response from them yet.!





Quote:
Originally Posted by Mal View Post
I have tested the climate setting but won't use it much until I figure out the HVAC system in normal operation....
HVAC system ?? Cold or hot climate ?
Attached Thumbnails
Click image for larger version

Name:	UVO-lafe005.jpg
Views:	58
Size:	48.5 KB
ID:	4973   Click image for larger version

Name:	UVO-other user phev.jpg
Views:	51
Size:	51.5 KB
ID:	4975  

Eric, The Canadian Guy !!


Kia Niro 2019 - PHEV SX - Snow White Pearl (15500 km)

Kia Niro 2018 - HEV EX 9000 km - Ocean Blue (Deep Cerulean) 6 months of pure pleasure.!!!



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
lafe005 is online now  
post #10 of 42 (permalink) Old 05-10-2019, 08:33 PM
Mal
Senior Member
 
Mal's Avatar
 
Join Date: Dec 2018
Posts: 141
Probably deserves a separate thread but I have trouble figuring HVAC out. From OFF if I start the fan I expect air from vents neither heated or cooled. I get heat or cool depending on temp set. IC starts and I get heat from the vents or the AC starts and cools the air. IF the AC runs, the AC light doesn't light.

Even after reading the manual, I've taken to setting a temp, deselecting recirculation and just letting it do its thing.
Mal is offline  
Closed Thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome