Kia Niro Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Normally my Niro automatic AC unit works great Its an EX premium but just lately the ac ,after driving a short while doesn't put out enough air to cool car. I over ride auto setting turn fan up to highest and it seems to do nothing just barely alittle air flow. I was thinking it slows down air flow like when making Bluetooth call but removed all phones to no avai Stop the car lety it sit for awhile and works great for short time...…...stumped!!!!!!
 

·
Registered
Joined
·
617 Posts
Sounds like it maybe losing Freon. Time to take it to the dealer.
 

·
Registered
Joined
·
512 Posts
How many miles on the car? What part of the world do you live in (what sort of climate)? If you've put a fair number of miles on the car, or if you live in a dusty environment, have you considered that you might need to replace the cabin air filter? The fact that you're saying "little airflow" does sound like it might be caused by a plugged up air filter kind of problem. Bluetooth is unlikely to have anything to do with it.
 

·
Registered
Joined
·
149 Posts
Do you have the auto turned off and the fan all the way up with the a/c on the lowest temp? Is the air that's coming out cold? Air not cold is probably some type of compressor or freon problem. Air not blowing hard enough could need a new cabin filter or something else is wrong with the blower fan.
 

·
Registered
2018 Niro EX Touring Graphite Edition
Joined
·
64 Posts
It's possible your evaporator may be icing over. The cabin air filter, if clogged, may not be allowing sufficient airflow thru the evap coils. If you live in a very humid climate it wouldn't take long to clog with ice. Cabin air filters are usually bypassed if you switch to recirculation mode. Have you tried that?
Insufficient airflow thru the evaporator or the system is overfilled with freon(right amt good more is not better), can cause ice to form on the coils, and can eventually block airflow completely but in every case it is always temporary. It will begin to melt as soon as you shut the a/c off.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #6 ·
OK update on my problem...After 3rd trip to dealer same problem after short distance drive AC on automtic 72 degrees setting air stops coming out of dash vents. Turn fan manually on high hear the fan blowing still nothing coming out. Dealer has reinstalled software, changed head unit for controls and checked freon....all to no avail.
None of the controls work, I checked and removed cabin filter to no avail. Funny thing you shut it off wait awhile works fine for short trips Dealler stumped in contact with KIA trying to work it out.....Any Comments????
 

·
Registered
Joined
·
893 Posts
OK update on my problem...After 3rd trip to dealer same problem after short distance drive AC on automtic 72 degrees setting air stops coming out of dash vents. Turn fan manually on high hear the fan blowing still nothing coming out. Dealer has reinstalled software, changed head unit for controls and checked freon....all to no avail.
None of the controls work, I checked and removed cabin filter to no avail. Funny thing you shut it off wait awhile works fine for short trips Dealler stumped in contact with KIA trying to work it out.....Any Comments????
Sounds like a mechanical problem to me. Something like the squirrel cage is not properly attached to the fan motor shaft and so it starts slipping after a while. Has the dealer actually looked at the blower assembly or have they just looked at the controls? If turning the fan on manually doesn't work then I would think the problem is with the actual working bits, not the controls.

Good luck, this sounds like a gnarly one to troubleshoot. :confused:
 
  • Like
Reactions: lafe005

·
Super Moderator
Joined
·
598 Posts

·
Registered
Joined
·
3 Posts
OK update on my problem...After 3rd trip to dealer same problem after short distance drive AC on automtic 72 degrees setting air stops coming out of dash vents. Turn fan manually on high hear the fan blowing still nothing coming out. Dealer has reinstalled software, changed head unit for controls and checked freon....all to no avail.
None of the controls work, I checked and removed cabin filter to no avail. Funny thing you shut it off wait awhile works fine for short trips Dealler stumped in contact with KIA trying to work it out.....Any Comments????
So I have 2019 Niro PHEV. About 36k miles.Recently I noticed the AC was not as cold just cool air. Took to the dealer 2x they say it tested fine. It started to make a pssst. noise when I first turned it on and off. It's getting HOT here in Florida and now it is warm air not cold blowing from AC. Took to the dealer and they said the AC needed to be evacuated and recharged with Freon?? What why? Where did it leak out? Dealer said it's because I have 35k miles. BS I have been driving a new Kia Sportages every 2-3 yrs since 1999 and never had to do that with AC. So I paid $150 to get it recharged. It got cold and worked for 2 weeks then started to get cool and warm air again. Went back to the dealer and they replaced the Evaporator core. Apparently it is a problem with the Optimas. My dealer has replaced 16 Optima evaporator cores but this was the 1st Niro. It was making the same noise as the Optimas do before it goes out. It was a big job, they had to remove the complete dashboard to get to it. Thankfully it was all covered under warranty. So far it is icey cold on #1 for 2 weeks now. I am keeping my fingers crossed no more problems with this Niro!
 

·
Registered
Joined
·
82 Posts
Similar happens to my first Niro: during the first warm days I recognized that the AC does not work. So I made an appointment by my dealer. My Niro was MY2016 and about 110.000 km. The first, what the service man said to me when I brought the car, all will be covered under warranty. After research the told me, that somewhere the AC was leaking and it will take some time to repair, because the had to remove the complete dashboard ...
But then I discussed this with my seller and at the end I decided to change for a new Niro occaison and it is now a Niro MY 2020 with 24.000 km ... I love the Niros ...
 

·
Super Moderator
2019 Niro PHEV EX Premium
Joined
·
1,661 Posts
Dealer is dealing BS claiming it's leaked out at 35k miles. Also, cars don't use Freon (R-12) any longer. It was replaced with R-134a a long time ago (mid '90s), and it's not as good at its job as R-12 was. But environmentally it's much better. R1234yf is now slated to replace R-134a. Apparently it is already mandated in Europe, while the US requirement was thrown out in court. I can't find a recent reference if it's going to be required here, but according to at least one site I read Kia already uses it.
 
1 - 12 of 12 Posts
Top