Kia Niro Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
I was on a long trip and the heater just slowly stopped putting out heat in my 2019 Niro PHEV. The engine tempter was just fine and their was now check engine lights etc. showing. Just slowly the hot air faded away to cool out side ambient temp. The fan still works and I can dial up the temp. but no hot air.


Any Ideas guys as to what's going on? I'm taking it in next week as it's only got 11,000 to date trouble free miles.
 

·
Super Moderator
2019 Niro PHEV EX Premium
Joined
·
1,385 Posts
I was on a long trip and the heater just slowly stopped putting out heat in my 2019 Niro PHEV. The engine tempter was just fine and their was now check engine lights etc. showing. Just slowly the hot air faded away to cool out side ambient temp. The fan still works and I can dial up the temp. but no hot air.


Any Ideas guys as to what's going on? I'm taking it in next week as it's only got 11,000 to date trouble free miles.
Sounds like a hose blockage of some sort. Hopefully it's just in a hose and not in the heater core itself. The core would mean dismantling some of the dash, never a good idea in a dealership. But it will covered under warranty, I'm sure, so no cost to you.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5
Dropped it off at the dealer today. While on they way there I was playing with the heater and it would run intermittently each time in the auto mode for a short time then the auto mode light would go out and no more heat..... Looks like it will not hold itself in auto mode...... Might be the button. Time will tell.
 

·
Super Moderator
Joined
·
593 Posts
Keep us posted!
 

·
Registered
Joined
·
2 Posts
Had the same issue with my 2018 EX at 120k mi. Discovered the coolant level very low, topped it off and heat problem solved.Two weeks later same problem, low coolant level and no heat, uh oh, wheres it all going?
Out the tail pipe thats where; had a steady cloud of steam trailing me upon acceleration.
Diagnosed it as a blown head gasket and traded it in without mentioning the issue.
End result was a monthly payment 98 bucks higher.
Call me crazy for buying the same model, but love the niro
 

·
Registered
Joined
·
5 Posts
Sounds like a hose blockage of some sort. Hopefully it's just in a hose and not in the heater core itself. The core would mean dismantling some of the dash, never a good idea in a dealership. But it will covered under warranty, I'm sure, so no cost to you.
Mine did that and it turned out to be a bown head gasket.
 
1 - 8 of 8 Posts
Top