Kia Niro Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
I have had my 2020 Niro hybrid for about three months. I get in the car today to come to work and my screen looked like it was loading from top to bottom, except it stopped halfway through the date at the top and then looked like the screen was broken. I turned the car off, turned it back on again and nothing. Weird thing is it was still "reactive" to the touch. I know this because I tapped it (thought maybe a loose connection or something) and I heard the beep of whatever I touched. By the time I go to work, it was just a black screen with a bit of the date showing (pictures attached.) First pic is what it was when I started the car and second picture is when I got to work. I'm super annoyed as the car is only three months old. I bought it brand new off the lot with like 20 miles on it. I believe it's under warranty but still.....

infotainment 1.JPG
infotainment 2.JPG
 

·
Registered
Joined
·
99 Posts
Did you try a reset? With a small pin into the hole right of the volume button ...
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #3 ·
Did you try a reset? With a small pin into the hole right of the volume button ...
I have not... not yet. A) I was driving B) didn't have anything small enough to stick in there. And since it was slightly different from what I am seeing on here, didn't know if it would work. Super strange though and not happy since my baby is only 3 months old. I think I'm gonna make a surprise visit to the dealership after work. This is just crazy. lol
 

·
Super Moderator
2019 Niro PHEV EX Premium
Joined
·
1,749 Posts
The pinhole reset might work, but that looks more like a video driver failure. Not certain a reset will do the trick. But you are absolutely still under warranty for something like that.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #5 ·
The pinhole reset might work, but that looks more like a video driver failure. Not certain a reset will do the trick. But you are absolutely still under warranty for something like that.
Agreed. Even the back up camera didn't pop up. So I'm like hmmmmm. I'm blown away, although this is my first Niro, this is like my 4th Kia and NEVER had any problems like this. I mean in my Fortes sometimes the screen would go blank or freeze but it was rare and would fix itself when I turned it off / on again. so this just blows me away.
 

·
Registered
Joined
·
99 Posts
The AVN works like a normal computer and these have also sometimes hick up's ... try the reset and when this does not help, back to the dealer ...
 

·
Registered
2020 Niro PHEV DynamicPlusLine
Joined
·
15 Posts
The pinhole reset might work, but that looks more like a video driver failure. Not certain a reset will do the trick. But you are absolutely still under warranty for something like that.
I fully agree.
I had my third display unit within 9 months and now it works ok. The original and first replacement didn't start correctly: it showed the waiting loop very long (over half an hour) and didn't respond to button presses (only the radio and nav button worked, the rest was unsure). A bad batch?
It was all handled under warranty and I received a dinner for 2 and a free first service (15k). Big hand for this dealer.
 

·
Super Moderator
2019 Niro PHEV EX Premium
Joined
·
1,749 Posts
I fully agree.
I had my third display unit within 9 months and now it works ok. The original and first replacement didn't start correctly: it showed the waiting loop very long (over half an hour) and didn't respond to button presses
That's a different issue. Yours was the entire infotainment system, while AzKhaleesi's is just the display. Of course, you can't just replace the screen, so they will have to replace the entire system anyway. :)
 
1 - 9 of 9 Posts
Top