Kia Niro Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello All,

My blower has stopped working completely. When I trigger the blower to run, the car engine shuts on if I'm idling but nothing blows out of the vents. It used to not work intermittently but now it doesn't shut on at all. Very frustrating. HELP!
 

·
Registered
Joined
·
3,100 Posts
Turn the fan up higher! Check where the air flow is directed. If it is trying to defog, you are not going to get air out of the middle vents.

If it is trying to defog unnecessarily, you can take back full control by turning the auto defog off - press and hold the front defrost button for a couple seconds.
 

·
Registered
Joined
·
26 Posts
My 2017 FE started doing this around 152K. It's intermittent for now but always comes on after about 10 minutes of driving. Once on, it works normal. Really sux at 3:30 am when the windshield is fogged out and you don't have defrost, or when passing a lake or overpass and it suddenly fogs over. Can you say safety issue? I've got another 4K left on this oil change so I will have it checked out next service. Should be sometime next week. I suspect it's the computer and not necessarily failed hardware, we'll see.
 

·
Registered
Joined
·
3,100 Posts
You might try a manual reset of the head unit. Pinhole next to the volume knob.

Cracking a front window usually takes care of fog on the windshield. Cold for the occupants, but safer than fog until you fix the fan.
 

·
Registered
Joined
·
26 Posts
It's probably a bad HVAC blower motor. It's fairly easy to replace and it cost about $140 shipped. Took me less than 10 minutes to pull the cover, 1 plug, 3 screws, swap motors and reverse order, done! A real mech with a good back, maybe 5 minutes top. Here's a link to the PDF to do it yourself, Kia Niro : Blower Motor Repair procedures : Blower . The dealer wants over $330 to do the job.
 
1 - 6 of 6 Posts
Top