Kia Niro Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Good Day Readers,

I bought my 2017 Niro last march of 2017, after 2 months of driving, It's always show up Hybrid Control system and I need to pull over at the side of the road to turn off and turn on again but the check engine on.

(June 2017) I drop it off the at dealership to take a look on the car, but they didn't see anything on hybrid control or DC/DC Converter.

It always happen to me since then and it's really inconvenient

I drop off my car at dealership last 13th of Dec. to fix the problem and service as well. Apparently, technician informed me that they did not find nothing wrong diagnostics or faulty wirings.
It seems like they cannot find the problem on my car.
I call the 800 number for consumer affair and will get back to me after couple of day.

I love my NIRO but I'm losing hope.

PLEASE HELP!
 

Attachments

·
Registered
Joined
·
35 Posts
I'd be all sorts of pissed off, esp if I had pictures with timestamps showing the alerts and they say that the systems logs etc don't show anything wrong. My car doesn't do this and I'd be talking lemon law with the dealer quite soon. Something is broken, they should fix it. Or give you a new one.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Jmcging - I totally understand you. I'm picking up my car soon, and if that thing show again in my dash board, I should take a lemon law. Service dealer will always tell customer that there's nothing wrong with your car, because they can't make money out of you due to under warranty. If you are not in warranty, all the sickness or malfunction on car will suddenly appears for no reason.
 

·
Registered
Joined
·
15 Posts
Service departments usually love to do warranty work, as they are reimbursed by the manufacturer for their work.

I'm surprised that the computer didn't store and report the reason for the malfunction. Niros are pretty new, so the techs at your dealership may not have seen this problem before. If it happens again, you may want to try another dealership.

I would suggest you also get a notebook and record the date/time each time this happens. If it happens repeatedly, and the dealers still can't find anything, try to elevate this to the next level and send your information to Kia. The notebook record will help you to establish your troubles and demonstrate that you have a lemon and if you qualify for a lemon-law replacement.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
yyysguy - I pick up my car from dealership last Saturday and they told me they can't find any thing wrong with it. Sunday night, and today (Monday) It show up again.

I spoke to KIA USA consumer agent and I declared that I have a LEMON CAR.

I'm done with this mess.
 

·
Registered
Joined
·
3 Posts
Keep Calling

Good Day Readers,

I bought my 2017 Niro last march of 2017, after 2 months of driving, It's always show up Hybrid Control system and I need to pull over at the side of the road to turn off and turn on again but the check engine on.

(June 2017) I drop it off the at dealership to take a look on the car, but they didn't see anything on hybrid control or DC/DC Converter.

It always happen to me since then and it's really inconvenient

I drop off my car at dealership last 13th of Dec. to fix the problem and service as well. Apparently, technician informed me that they did not find nothing wrong diagnostics or faulty wirings.
It seems like they cannot find the problem on my car.
I call the 800 number for consumer affair and will get back to me after couple of day.

I love my NIRO but I'm losing hope.

PLEASE HELP!
Call every day to keep up with this. The squeaky wheel gets the oil. I had a brake module issue and called every day (sometimes 2 or 3 times) and it was amazing the amount of service I received, even if it was to just shut me up. However, my vehicle was fixed and I have not had a problem since (4000+ miles).
 

·
Registered
Joined
·
24 Posts
I'm glad I'm not the only one having a problem with a dealer. I have about 11,000 miles on mine and when it turned cold the gas mileage went down a way to far in my thinking. Called the dealer and got the run around about all the things I had already done. Any way, I started watching the engine temp gauge and could drive 5 miles before it would even start to warm up, so was running with a cold engine unless I was out on the highway and then it was ok. So when I took it in for an oil change, I told them that the engine was not coming up to temp and they said they would check it out. 20 minuets later they had the car back out and said it was checked out and everything was ok. Well, I've worked on cars for about 60 years and would guess that the thermostat is not closing all the way if at all and Kia has now put on the complete service manual on line and I had already look at it. After I confronted service manager he went and got the guy that had worked on my car and he said it didn't have a thermostat in the cooling system. He also said he had went to school for 3 days to learn how to work on the Niro. For the life of me, I don't know how they can keep a guy like that. I haven't talked to another dealer yet or made any phone calls but take care of it after the first of the year. By all means, do Not take a car to the dealer in Mankato, Mn. Also, now my resume on my cruse has quit working now..
 

·
Registered
Joined
·
45 Posts
I am in Minneapolis and in the winter I really have never had a car start to warm before 5 minutes of driving. I’d recommend an engine heater for that. It’s like 17 degrees this morning so yeah it will take some driving to heat the engine up. I have noticed this winter, in stop and go traffic, that when the gas engine is not running much that the engine can cool way down, it was quite interesting to watch the gauge. I still had heat but it dropped down to one mark on the gauge. It’s a shame about the cruise, I don’t use mine much but works great when I do. That is certainly still covered by warranty and sounds like it should be an easy problem to reproduce. Good luck!
I'm glad I'm not the only one having a problem with a dealer. I have about 11,000 miles on mine and when it turned cold the gas mileage went down a way to far in my thinking. Called the dealer and got the run around about all the things I had already done. Any way, I started watching the engine temp gauge and could drive 5 miles before it would even start to warm up, so was running with a cold engine unless I was out on the highway and then it was ok. So when I took it in for an oil change, I told them that the engine was not coming up to temp and they said they would check it out. 20 minuets later they had the car back out and said it was checked out and everything was ok. Well, I've worked on cars for about 60 years and would guess that the thermostat is not closing all the way if at all and Kia has now put on the complete service manual on line and I had already look at it. After I confronted service manager he went and got the guy that had worked on my car and he said it didn't have a thermostat in the cooling system. He also said he had went to school for 3 days to learn how to work on the Niro. For the life of me, I don't know how they can keep a guy like that. I haven't talked to another dealer yet or made any phone calls but take care of it after the first of the year. By all means, do Not take a car to the dealer in Mankato, Mn. Also, now my resume on my cruse has quit working now..
 

·
Registered
Joined
·
50 Posts
I am in Minneapolis and in the winter I really have never had a car start to warm before 5 minutes of driving. I’d recommend an engine heater for that. It’s like 17 degrees this morning so yeah it will take some driving to heat the engine up. I have noticed this winter, in stop and go traffic, that when the gas engine is not running much that the engine can cool way down, it was quite interesting to watch the gauge. I still had heat but it dropped down to one mark on the gauge. It’s a shame about the cruise, I don’t use mine much but works great when I do. That is certainly still covered by warranty and sounds like it should be an easy problem to reproduce. Good luck!

I noticed the same thing with the temp gauge on my Niro - it seems to warm up and go down to one bar when using the heat.


On my prius(s) I was told they used a separate heat reservoir for the heading system which contained and stored some of the heat and the cooliant was heated by the exhaust. When the Toyota Tech told this I thought what a great idea, to test it, I checked the car one cold day, I warmed it up on lunch, then 4 hours later I left work. I'd did get warm air prior to the engine warming up.


I'm guessing the Niro just uses the standard engine & radaitior/heater core system - but I don't know this for a fact.


Kind of hoping down the road we get a Kia tech to join this forum :)
 

·
Registered
Joined
·
125 Posts
I noticed the same thing with the temp gauge on my Niro - it seems to warm up and go down to one bar when using the heat.


On my prius(s) I was told they used a separate heat reservoir for the heading system which contained and stored some of the heat and the cooliant was heated by the exhaust. When the Toyota Tech told this I thought what a great idea, to test it, I checked the car one cold day, I warmed it up on lunch, then 4 hours later I left work. I'd did get warm air prior to the engine warming up.


I'm guessing the Niro just uses the standard engine & radaitior/heater core system - but I don't know this for a fact.


Kind of hoping down the road we get a Kia tech to join this forum :)
You toggle to your temp gauge? I don't ever use it. I just keep my MPG on my screen.
 

·
Registered
Joined
·
453 Posts
I have engine water temperature on my Ultra gauge so I can see it all the time. It is unremarkable, behaves like every other vehicle I have ever owned. It gets warm when the ICE runs and cools down when it shuts off.

I rarely use the heater, instead I use the seat heaters.
 

·
Registered
Joined
·
469 Posts
Interesting operation for Cold Weather. So, far not had any real cold (bought car Feb 2017) in TN.

Did notice MPG display lower last tank. Filled it TUE EVE, need to post on FUELLY, about forgot. I have not computed MPG - but display was lower than usual (48MPG range where has been more like 52MPG).

Just filled out FUELLY Fill Up --- at 10009 miles 9.756 Gallon for 495 miles = 50.7 MPG (not far off my average)
 

·
Registered
Joined
·
6 Posts
Discussion Starter #15
Call every day to keep up with this. The squeaky wheel gets the oil. I had a brake module issue and called every day (sometimes 2 or 3 times) and it was amazing the amount of service I received, even if it was to just shut me up. However, my vehicle was fixed and I have not had a problem since (4000+ miles).
I calling them almost everyday. of course they have alibi that the Manager is out of office. Thanks for advised!
 

·
Registered
Joined
·
6 Posts
Discussion Starter #16
Dear Readers,

I always call the KIA Consumer agent since the problem started. They always telling me that the Manager is out of office or vacation. My patient is running out. I hope they could fix this next week or before the end of the year.
If they didn't make any solution, I will take a necessary route (LAWYER).

If Y'all having this problem, this could make your way temporarily.

**Warm up the for 10 minute.

***Drive the car on Sports Mode. (I THINK the ECO mode is messing up the Hybrid control system specially if the weather is cold)

Let me know what you think.
 
1 - 18 of 18 Posts
Top