Kia Niro Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
76 Posts
Discussion Starter #1
Hi,
24H with the niro now and I noticed that on the "auto" setting, the light stays On most of the day even on bright sunny day...unless when I have the sun fully in front of the car near midday...
the rest of the testing conditions leads to lights ON.
did you notice this and what did you do to solve this issue? dealer/yourself? any possibility that a sheet of protection film filters the light? where is the photo sensor?
thank you
 

·
Registered
Joined
·
318 Posts
I have just the opposite problem. When in auto on my Niro the lights don't come on until it's fairly dark out so I wind up turning them on myself anyway. Perhaps your sensor is taped over or something like that. Not sure where the sensor is but I'm sure somebody else on here can tell you.
 

·
Registered
Joined
·
394 Posts
In auto mode, the daytime headlights are (almost) always on. The manual says they turn off if you set the parking brake. I use auto mode and the (night time) headlights always come on when I'm in the garage. It seems to take several seconds after I've backed out of the garage and into daylight before they turn off: I assume that there's some sort of delay logic that keeps the sensor from automatically turning them on/off for temporary changes in lighting. Occasionally they seem to stay on for a few minutes if it's a cloudy day. Once the headlights are on, if you have the "Escort" feature enabled, it will keep them on for a time after you turn off the car.


I don't know for certain where the light sensor is located. I assume it might be in the housing on the windshield in front of the rear-view mirror. But now that I think about this, that might be a problematic location, because it would be exposed to oncoming headlights at night. I wonder if there is a light sensor somewhere in the cabin?
 

·
Registered
Joined
·
76 Posts
Discussion Starter #6
for what I read it might be on center of dashbord where the red "alarm" LED light is... not sure if true but it would not be a surprise
 

·
Registered
Joined
·
178 Posts
Hi,
24H with the niro now and I noticed that on the "auto" setting, the light stays On most of the day even on bright sunny day...unless when I have the sun fully in front of the car near midday...
the rest of the testing conditions leads to lights ON.
did you notice this and what did you do to solve this issue? dealer/yourself? any possibility that a sheet of protection film filters the light? where is the photo sensor?
thank you

2017 EX here, I always have "auto" enabled for the lights. Once in a great while, the headlights will come on and NOT turn off even in bright sun. To solve this, I manually turn them OFF, then back ON, and only the daytime LED lights are on as they should be...... could be a glitch..........try manually turning off and back to ON, that might initiate some sort of reset, it's worked for me,,,,,,,,,,happens RARELY
 
1 - 7 of 7 Posts
Top