Kia Niro Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
69 Posts
Discussion Starter #1
I like all of the features that are shown on the display panel, but I haven't found any sign of a temperature gauge. Is there a dedicated display for engine temperature?
 

·
Registered
Joined
·
5 Posts
engine temp gauge always reads hot

engine temp gauge As I was familiarizing myself with the various screens I opened the engine temp gauge window and saw that it was all the way up with a red rectangle around the top. I've been driving in straight EV mode for weeks now, so don't see how the engine cold be anything other than cold. I have not seen any temperature warning icons on the main screen. Anyone know anything about this? Thanks,
 

·
Registered
Joined
·
463 Posts
My Ultragauge has a temperature gauge. The regular hybrid ICE runs just over 200 degrees after it is warmed up and running.

Seems just about right to me.

I wonder if your gauge isnt working because the engine isnt running. Perhaps it needs to run to "reset".
 

·
Registered
Joined
·
5 Posts
Thanks, Griswald but I think I figured it out. That red thing at the top of the thermometer is just part of the graphic display, rather than an actual indication. I don't think it's reading anything because with the gas engine off it's just not an issue. Next time the gas engine is running, which I expect to be about a month from now, I'll check back and see what an actual indication looks like.
 

·
Registered
Joined
·
2,971 Posts
It so far only goes to one bar under half "hot" in my HEV. Yes, there is a red bar on top of the graph but the indicator never goes that high. Hopefully there is an idiot light that comes on before that happens.
 
1 - 7 of 7 Posts
Top