Kia Niro Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
ok, bear with me.I bought a brand new PHEV 2019. I've driven it 60,220 as of now for work. I was driving about 300 miles a day, now it's more like 300 a week. Regular oil changes every 5000 instead ofthe recomended 7200.

when Ifirst pulled out of the lot I noticed there Was a lag in the relay from letting offthe brake about 1.5 sec before pressing the accelerator before it would even move. this happens when I let up off the brake fast and go to "punch" it.

then one morning I went to unplug it and it wouldn't unplug.

then the instrument display started intermittently blacking out, it does this every month or so. If I'm driving at night I can't see how fast I'm going when this happens

then the engine light came on after shifting to hybridmode and then climed the small grade of my driveway,it it stayed in high gear and redlined. the light stayed on for a little while and then I never saw it again, until, climing a grade onthe freeway the engine threw a rod. It was replaced with a warranty engine. All has been fine, until today, in hybrid mode, climbing the slight grade in my drive, as I come tothe top, and am pressing the brake, it acted like itwas stalling or running out of gas, and threw a code and said multiple conditions had just occurred in the engine.

I've already contacted KIA, and they've put me at the top to speak to a third party arbiter about the car. I want out of it and put into a new car.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #2 ·
It also stalled and reported an issue turning over the engine one morning it was 13 degrees.and it continued until I switched back and fourth from hybrid to Ev modes several times
 

·
Registered
Joined
·
410 Posts
Sheesh Jared, that is tough luck; you've had your share of problems! :eek: I don't recall seeing any other posts about Niro engine's needing replacement. While I don't know the lemon laws in your state, on the surface sounds like you may have a case for a free replacement.
How many miles did you have when the 1st engine threw a rod? Did Kia give you any reasons as to why your car was acting strange before that happened? Sounds like you had electronic motor control issues. Did they replace any of the electronics when they replaced the engine?
 

·
Registered
Joined
·
3,170 Posts
when Ifirst pulled out of the lot I noticed there Was a lag in the relay from letting offthe brake about 1.5 sec before pressing the accelerator before it would even move. this happens when I let up off the brake fast and go to "punch" it.
This is probably the hill hold feature you are experiencing here. Considering the rest of your post, I doubt you are really concerned with this right now, but there is a workaround.
 
1 - 4 of 4 Posts
Top