Kia Niro Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1 (Edited)
My clunk started at 80K when I had an oil change done. Now at 84K. It was a now and then random noise. I only noticed it because it was on the driver/front side and I always had the window open. Sounds just like others have described, brake pad being slid into a rotor. it now happens a good 95% of the time just before a full stop and 1-2 sec. after starting up. But NEVER in sport mode. And if I use sport mode for an extended time, when I go back to auto, the clunk is not there. It is as if the sport mode fixed what ever was making the noise.

Edit, I took my car in and it was diagnosed as a worn c/v joint on the d/s axel. 3-4 days to get the part, 1 hour to install.
 

·
Registered
Joined
·
95 Posts
My clunk started at 80K when I had an oil change done. Now at 84K. It was a now and then random noise. I only noticed it because it was on the driver/front side and I always had the window open. Sounds just like others have described, brake pad being slid into a rotor. it now happens a good 95% of the time just before a full stop and 1-2 sec. after starting up. But NEVER in sport mode. And if I use sport mode for an extended time, when I go back to auto, the clunk is not there. It is as if the sport mode fixed what ever was making the noise.

Edit, I took my car in and it was diagnosed as a worn c/v joint on the d/s axel. 3-4 days to get the part, 1 hour to install.
Worn c/v joint makes perfect sense. Surprised this happened - these days, these should last the life of the car. Presume it was covered under warranty?
 
1 - 2 of 2 Posts
Top