Kia Niro Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
good afternoon. An error has occurred “check hybrid system, turn engine off”. the car will not start, but this error only lights up. sometimes only the electric motor can turn on, and the engine is not connected in the future. Has anyone encountered such a problem?
 

Attachments

·
Registered
Joined
·
58 Posts
I've not experienced it, but I bet if you did a search on these forums, you would find some info. Unfortunately, this is probably the type of problem that will require a trip to the dealership. :(
 

·
Registered
Joined
·
788 Posts
good afternoon. An error has occurred “check hybrid system, turn engine off”. the car will not start, but this error only lights up. sometimes only the electric motor can turn on, and the engine is not connected in the future. Has anyone encountered such a problem?
I have the PHEV version so not exactly apples to apples, but I have on occasion seen a similar message a couple of times. In my case simply turning the car off and then on again clears the error. I've had the car for 18 months and it's happened maybe a handful of times.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
diagnostics showed that there is an error P17E2 but I do not know what kind of error it is
 

·
Registered
Joined
·
3 Posts
I have 2019 and last night the P17E2 came up for me. Wondering if you found out any information regarding your trouble code.
 

·
Super Moderator
2019 Niro PHEV EX Premium
Joined
·
1,263 Posts
I have 2019 and last night the P17E2 came up for me. Wondering if you found out any information regarding your trouble code.
The only thing I could find online for P17E2 was that it is a generic code that a manufacturer could use for anything. Apparently if the first digit (other than the letter) is anything but a zero it's a manufacturer specific code and only they can tell you what it stands for. I did find one page that had some P17 codes, but none that matched this. And the four P17 codes didn't seem isolated to any one particular area.
 

·
Registered
Joined
·
3 Posts
Thanks for the info. I called a dealership a couple days ago, they said it was a transmission code and to schedule an appointment. Also said that if the check engine light was not flashing, the it should be ok to drive it in. Not sure why the first warning said to shut the engine off immediately?
 

·
Registered
Joined
·
3 Posts
It appears that the system warning has stopped. The car was parked in the garage since Sunday (Thursday today), I went out to take a pic of the warning in the dash and when I turned the key on.... nothing. The check engine light is still on, but no warning to shut the car off error in the dash display. I drove the car and it appears to be operating fine. Going to clear the code tomorrow and see what happens. I'll keep you posted.
 
1 - 8 of 8 Posts
Top