Kia Niro Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi all, got a new 2019 Niro a few weeks ago and so far pretty happy with it. I just have one problem. Almost every time that I'm using Android auto and using the navigation, the radio stops after the voice prompt.

I can hear the radio still playing in the background while the voice prompt is still talking. But as soon as it finishes speaking, the radio seems to just turn off. If I mute the navigation prompts, I have no problems.

Once in a while the radio will keep working after the voice prompt. But so far I haven't noticed a pattern as to when that happens.

Anyone else have this problem? I'm not even sure if it's a problem with the car, Android auto, or my phone (Galaxy s8 plus)
 

·
Registered
Joined
·
2,012 Posts
It does the same with Apple Carplay. One workaround is to stream the radio, then navigation interrupts work as designed. It would be interesting to learn if this is a global bug that affects all car brands, or just Hyundai/Kia. First time I've used it in a car personally.
 

·
Registered
Joined
·
240 Posts
I've got Apple CarPlay in my 2017 VW. That doesn't happen, nor should it happen. Sounds like a PIA.

Is everyone having that issue or is it an outlier? Has anyone talked to their dealer about it to find out if it is just a setting or a bug or "normal"?
 

·
Registered
Joined
·
412 Posts
I've got Apple CarPlay in my 2017 VW. That doesn't happen, nor should it happen. Sounds like a PIA.

Is everyone having that issue or is it an outlier? Has anyone talked to their dealer about it to find out if it is just a setting or a bug or "normal"?
I have to say I've never had this issue in my '18 PHEV Niro. I use Android Auto for navigation and it interacts with the radio just fine. The radio volume is muted (in the front only, which is pretty cool) during the navigation prompts and then returns to normal. Works for reading texts too.
 

·
Registered
Joined
·
54 Posts
Hi all, got a new 2019 Niro a few weeks ago and so far pretty happy with it. I just have one problem. Almost every time that I'm using Android auto and using the navigation, the radio stops after the voice prompt.

I can hear the radio still playing in the background while the voice prompt is still talking. But as soon as it finishes speaking, the radio seems to just turn off. If I mute the navigation prompts, I have no problems.

Once in a while the radio will keep working after the voice prompt. But so far I haven't noticed a pattern as to when that happens.

Anyone else have this problem? I'm not even sure if it's a problem with the car, Android auto, or my phone (Galaxy s8 plus)
So I have noted the same thing, but it seems to be phone and app dependent. I've noticed it occurring with Android 8 and Waze, and now that I'm using Android Q, I see it again. I've filed a bug report with Google because it's an Android Auto bug, not the Niro. I've seen the same issue in forums on other Kia's and on the BMW 340i
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
Sorry i didnt reply sooner - i didnt get any new message notifications for some reason. Anyhow....

So i noticed one other thing thats a little buggy and I'm wondering if it might be related.
I noticed that every time I plug my phone in, at the top of the cars screen it shows a amazon song - one that I had asked it to play a while back. But now I can't get rid of it. In fact, i can clear that playlist out of my phone, but then as soon as I plug it back into the car, that playlist comes right back. I don't suppose anyone else with this radio/voice prompt issue also has a stuck playlist?

I also just thought of something else which I'm going to test next time I'm in the car...I have a roav viva in the car so I can use alexa while driving. I think I used that to start playing the music last time. I wonder if the plugin mic or their app might be causing an issue. I'll try unplugging it and/or uninstalling the app next time and see if anything different happens.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
So i've tried removing amazon music, google play music, and roav viva, and none of it helps.

The only thing I've noticed is that after uninstalling one of the applications, it seems as though the voice nav works correctly the first time i use it. But then it just goes back to cutting off the radio after it finishes speaking.
 

·
Registered
Joined
·
366 Posts
My Android Auto also shows some odd tendencies. Waze will freeze until I turn on the phone screen, doesnt need to be in the Waze app, just screen on. Sometimes Slacker Radio will only play one song and then quit, always finishes the song before stopping.

I just learned to live with it because 99.87% of the time it works well.

I also have a Samsung S8+ but also have a Galaxy S3 Frontier watch, so bluetooth and Android Auto are always on...things are bound to screw up. Oh, and my wireless dash cam is also running all the time.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #9
So - of course after i said it stopped working, it started working. Although it was just for a short trip. Although long enough that it would have usually stopped working. I'll keep trying it out the next few days. Try to figure out a pattern to it.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #10
well, now things really got complicated - my phone downloaded and installed android (pie) the other day, and since that happened, this issue hasn't occurred. Wish I knew what the cause was under android 8, but I can't test that anymore.
 
1 - 10 of 10 Posts
Top