Kia Niro Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Starting to wonder if this was a good purchase...had a problem with the car not moving when pressing the accelerator, which was fixed. Now there's an issue with the transmission (Potential Transmission Control Issue...contact your Kia dealership). Started 12/31 coming home in -15 temps, and the transmission wouldn't give any acceleration power. We could get up to speed, but the engine would race and wouldn't shift to give us any speed. Sport mode didn't work. Once we were up to speed, it worked okay until trying the cruise. Then it wouldn't shift down to maintain speed, so I just drove without. No check engine light. Got home and still had the problem. Tried again the next day and it worked fine...for 50 feet. Then the check engine light came on, the sport mode again wouldn't work and now it's sitting awaiting a chance to get to the dealership. I'm thinking Kia has an issue with the transmission that needs work. Not very happy with the car at the moment.
 

·
Registered
Joined
·
173 Posts
At -15 below zero, I don't doubt the transmission lube turns to glue! It's why when I lived in winters wrath, I had a engine block heater, transmission heater, water heater, and to top it off I ran a small electric space heater inside. That morning at 5 am it was -35 actual.. slid and bent rear axle, it was installed after pic was taken and had warmed up to 0.

See pic for my idea of a bad time..... a month after this pic was taken, I moved to Los Angeles.... warmth!
 

Attachments

·
Registered
Joined
·
19 Posts
Discussion Starter #3
Issue resolved. Not because of the cold, but a problem others are having as detailed on the Niro group on Facebook. The history showed it was unable to engage in gear 3, they opened a tech case with Kia engineers and essentially reset the computer and performed a DCT learning (teach the computer how to drive the car again). It's not common, but it has happened to others as well, even in warmer areas.
 

·
Registered
Joined
·
219 Posts
Issue resolved. Not because of the cold, but a problem others are having as detailed on the Niro group on Facebook. The history showed it was unable to engage in gear 3, they opened a tech case with Kia engineers and essentially reset the computer...
Will keep my fingers crossed for you. You’ve had enough! If something else goes wrong you may be into lemon law territory if you wish it. But hopefully you’ve used up your bad luck for a while.
 
1 - 4 of 4 Posts
Top